你在这里

安装Drupal

什么是PDO?

原文地址:http://drupal.org/requirements/pdo What is PDO?

PDO is an acronym for PHP Data Objects. PDO is a lean, consistent way to access databases. This means developers can write portable code much easier. PDO is not an abstraction layer like PearDB. PDO is a more like a data access layer which uses a unified API (Application Programming Interface).

Taxonomy upgrade extras: 

Drupal 8 注意事项

原文链接:http://drupal.org/node/1801864

Drupal 8 的运行环境需要 PHP 5.3.10 及以上版本。

Drupal 8 不再支持安装在php ini设置里开启了魔术引号功能('magic_quotes_gpc' 或 'magic_quotes_runtime')的服务器。这个功能在PHP 5.3里是不推荐的,不过在PHP5.4就移除了。

Change notice for this

Taxonomy upgrade extras: 

Drupal 7 注意事项

原文地址:http://drupal.org/node/1801862

Drupal 7 注意事项(notes)

Taxonomy upgrade extras: 

Drupal 6 注意事项

原文链接:http://drupal.org/node/1801862

Drupal 6 注意事项(notes)

  • 即便 PHP 5.3 被 Drupal 6.14核心或更高版本支持 (参阅 6.14发行说明),依然有一些贡献模块可能不兼容 PHP 5.3,而且有些 PHP 5.3 的配置在Drupal 6.14下仍然有警告提示;解决 #360605: PHP 5.3 兼容性里后者问题的工作也正在进行着。
Taxonomy upgrade extras: 

Drupal 5 注意事项

Drupal 5.x 不支持 PHP 5.3。

Drupal 5:PHP 4.4.0 或者更高 (推荐5.2)

Taxonomy upgrade extras: 

PHP

常见PHP的配置说明

Taxonomy upgrade extras: 

数据库服务器

推荐: MySQL (或者等效的数据库,比如 MariaDB)

  • Drupal 5.x 以及更早期的版本支持MySQL 3.23.17 或者更高版本,强烈推荐MySQL 4.1 或更高版本。
  • Drupal 6 支持MySQL 4.1 或更高版本。
  • Drupal 7 将只支持MySQL 5.0.15 或者更高版本,同时需要安装PHP的PDO数据库扩展 (查阅PDO是什么?)。
Taxonomy upgrade extras: 

Web 服务器

Drupal开发的站点可以运行在所有支持php的web服务器上。下面是一些常见的web服务器。

Apache (推荐)

The most commonly used web server software, notable for playing a key role in the initial growth of the World Wide Web

Taxonomy upgrade extras: 

《安装Drupal》英文手册目录

花了一些时间对官方提供的《安装Drupal》(Installation Guide)的目录进行了整理。可以看出,这一部分涉及到的内容颇为丰富,目前已完成的部分可能只有十分之一。

下面整理的英文手册的目录结构,方便申请翻译任务时查看和复制:

Taxonomy upgrade extras: 

《安装Drupal》翻译任务申领表

相关文章:

关于官方文档《安装Drupal》的翻译规划:http://drupalchina.cn/node/1483

如何参与Drupal官方文档翻译?http://drupalchina.cn/node/1498

《安装Drupal》英文手册目录:http://drupalchina.cn/node/1500

Taxonomy upgrade extras: 

页面

订阅 RSS - 安装Drupal