你在这里

drush运行不了?

主标签

按官方的安装说明
Install a site-local Drush
1.It is recommended that Drupal 8 sites be built using Composer, with Drush listed as a dependency. That project already includes Drush in its composer.json. If your Composer project doesn't yet depend on Drush, run composer require drush/drush to add it.
2.To run Drush, navigate to your Drupal root and call ../vendor/bin/drush.
并且chmod u+x /usr/local/vendor/bin/drush

在安装路径下/usr/local/vendor/bin/drush
运行drush: ./drush
出现以下错误:
PHP Warning: exec() has been disabled for security reasons in /usr/local/vendor/drush/drush/includes/startup.inc on line 32
PHP Warning: Invalid argument supplied for foreach() in /usr/local/vendor/drush/drush/includes/startup.inc on line 33
/usr/local/vendor/bin/drush.launcher: line 17: /usr/local/vendor/drush/drush/drush.launcher: Permission denied

查看文件:1。PHP Warning: exec() has been disabled for security reasons in /usr/local/vendor/drush/drush/includes/startup.inc on line 32内容为: exec('printenv', $env_items);
2.PHP Warning: Invalid argument supplied for foreach() in /usr/local/vendor/drush/drush/includes/startup.inc on line 33内容为:foreach ($env_items as $item) {
3./usr/local/vendor/bin/drush.launcher: line 17: 内容为:"${dir}/drush.launcher" "$@"

 

 

Drupal 版本: 

猜你喜欢