上海戴文 - Drupal开发 在线教育

你在这里

系统要求

原文地址:http://drupal.org/requirements

要安装和运行Drupal,您的虚拟主机必须满足一定的最低要求。大多数的虚拟主机都能达到这个要求。当然,一些特殊的配置也能对Drupal社区进行支持。如果您对托管有需求,可以考虑选择经我们审查通过的虚拟主机提供商

Drupal 的最低系统需求
(点击章节首部获取详细信息):

磁盘空间
      15 Mb
Web服务器
      Apache, Nginx, Microsoft IIS 或者其他 支持PHP的Web服务器。更多信息请查看Web服务器要求
数据库服务器

  • Drupal 8:
    • MySQL 5.5.3/MariaDB 5.5.20/Percona Server 5.5.8 or higher with PDO and an InnoDB-compatible primary storage engine
    • PostgreSQL 9.1.2 or higher with PDO,
    • SQLite 3.6.8 or higher
  • Drupal 7
    • 附带PDO的MySQL 5.0.15/MariaDB 5.1.44/Percona Server 5.1.70 或更高版本
    • PostgreSQL 8.3 或更高附带PDO
    • SQLite 3.3.7 或更高
  • Drupal 6:
    • MySQL 4.1 或更高
    • PostgreSQL 7.1

注意: Microsoft SQL ServerOracle 有附加模块来支持。

更多关于数据库要求的信息请查看这里

PHP

  • Drupal 8: PHP 5.5.9 或更高
  • Drupal 7: PHP 5.2.5 或更高 (推荐 5.4 版本)
  • Drupal 6: 仅适用于 PHP 5.x 或更高 (推荐 5.2.5 或者更高版本) (注意:支持 PHP 4.x 已经被放弃了。 Drupal core 是支持在 PHP 5.3.x 上运行的, 但是 PHP 5.3.x 和更高版本可能会引起错误或者不可预期的行为,尤其是对于第三方的模块和主题。)

更多关于 PHP 需求的详情, 包含了PHP memory.

注意:如果您的配置达到了系统需求,但站点依然存在问题,请务必通读虚拟主机常见问题FAQ

查阅Drupal.org的phpinfo()页来了解如何使用phpinfo来获知您的系统细节。举例来说,phpinfo会告诉您是否已经安装了一个数据库,以及系统运行的PHP、MySQL的版本等等。您的系统运行时,Phpinfo还会告诉您设置了哪些PHP变量以及其他许多有用的东西。

Comments

推荐初学者选择XAMPP的amp环境,摩羯座是完美主义者?总觉得开源的就该和开源的配在一起。开发用操作系统我选择Fedora,服务器的操作系统我选Centos,按照龙马翻译的drupal版本推荐的php版本,我在XAMPP中文用户组上查到的分享给年轻的drupaller们,D6对应的xampp版本是1.7.1,D7对应的xampp版本是1.7.7,D8当然是1.8.2了吧。如有错误还请更正,谢谢。后面是XAMPP下载链接https://www.apachefriends.org/index.html

XAMPP的确适合初学者,安装简易。